aboutsummaryrefslogtreecommitdiff
path: root/www/tntnet
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /www/tntnet
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'www/tntnet')
-rw-r--r--www/tntnet/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/www/tntnet/Makefile b/www/tntnet/Makefile
index 562722852901..410db2484c69 100644
--- a/www/tntnet/Makefile
+++ b/www/tntnet/Makefile
@@ -21,15 +21,15 @@ USE_ICONV= yes
USE_CSTD= gnu89
PATCH_STRIP= -p1
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
CONFIGURE_ARGS+= --localstatedir=/var
.if defined(WITH_GNUTLS)
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -lgnutls"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lgnutls
CONFIGURE_ARGS+= --with-ssl=gnutls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.else
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS+= --with-ssl=openssl
.endif