aboutsummaryrefslogtreecommitdiff
path: root/www/varnish
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2007-08-29 15:45:47 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2007-08-29 15:45:47 +0000
commit726c3bb71ae9a2c5b201b86cd41192034cc55a6b (patch)
treefa64e620d9c502659966d0037ac516042ea7e293 /www/varnish
parent70db96a028d6e9e74bfce44c4b1825f285023a48 (diff)
downloadports-726c3bb71ae9a2c5b201b86cd41192034cc55a6b.tar.gz
ports-726c3bb71ae9a2c5b201b86cd41192034cc55a6b.zip
Apply patch for Varnish bug #150.
Notes
Notes: svn path=/head/; revision=198496
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile2
-rw-r--r--www/varnish/files/patch-svn-r191318
2 files changed, 19 insertions, 1 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index 4d6b40d6aa2a..d4e869406d6a 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -7,7 +7,7 @@
PORTNAME= varnish
PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/varnish/files/patch-svn-r1913 b/www/varnish/files/patch-svn-r1913
new file mode 100644
index 000000000000..318666826f0e
--- /dev/null
+++ b/www/varnish/files/patch-svn-r1913
@@ -0,0 +1,18 @@
+Index: bin/varnishd/cache_center.c
+===================================================================
+--- bin/varnishd/cache_center.c (revision 1912)
++++ bin/varnishd/cache_center.c (revision 1913)
+@@ -524,7 +524,12 @@
+ */
+ WSL(sp->wrk, SLT_Debug, sp->fd,
+ "on waiting list on obj %u", sp->obj->xid);
+- assert(!isnan(sp->wrk->used));
++ /*
++ * There is a non-zero risk that we come here more than once
++ * before we get through, in that case cnt_recv must be set
++ */
++ if (isnan(sp->wrk->used))
++ sp->wrk->used = TIM_real();
+ SES_Charge(sp);
+ return (1);
+ }