aboutsummaryrefslogtreecommitdiff
path: root/www/yarr/Makefile
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-07-09 18:28:22 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-07-09 18:28:22 +0000
commit9d0bb93ec1fa400903e3634a79ceda614c0142d9 (patch)
tree765164887c1b960c71c2605b24e9377a459a2cba /www/yarr/Makefile
parentf8a0151c2fbfdfedd776234f07f7d0e30f2a2b50 (diff)
downloadports-9d0bb93ec1fa400903e3634a79ceda614c0142d9.tar.gz
ports-9d0bb93ec1fa400903e3634a79ceda614c0142d9.zip
www/yarr: Add new port
yarr (yet another rss reader) is a web-based feed aggregator which can be used both as a desktop application and a personal self-hosted server. It is written in Go with the frontend in Vue.js. The storage is backed by SQLite. WWW: https://github.com/nkanaev/yarr
Diffstat (limited to 'www/yarr/Makefile')
-rw-r--r--www/yarr/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/yarr/Makefile b/www/yarr/Makefile
new file mode 100644
index 000000000000..21b4c213f1fb
--- /dev/null
+++ b/www/yarr/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= yarr
+DISTVERSIONPREFIX=v
+DISTVERSION= 2.0
+CATEGORIES= www
+
+MAINTAINER= decke@FreeBSD.org
+COMMENT= Yet another rss reader
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/license
+
+USES= go:modules
+
+USE_RC_SUBR= ${PORTNAME}
+
+USE_GITHUB= yes
+GH_ACCOUNT= nkanaev
+GH_TAGNAME= 0c5385c
+GH_TUPLE= \
+ golang:net:d3edc9973b7e:golang_net/vendor/golang.org/x/net \
+ golang:sys:eeed37f84f13:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.0:golang_text/vendor/golang.org/x/text \
+ mattn:go-sqlite3:v1.14.0:mattn_go_sqlite3/vendor/github.com/mattn/go-sqlite3
+
+GO_TARGET= ./src/main.go:yarr
+GO_BUILDFLAGS= -tags "sqlite_foreign_keys release" -ldflags "-X main.Version=${PORTVERSION}"
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>