aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-07 08:06:24 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-07 08:06:24 +0000
commit54e279cd729c9bf5428e3d8423fec99fa7e97b8d (patch)
tree2de9381d204a65a62d4393ca3bb1a5b85c51daeb /www
parent15a23210ccc7af4d05fbe6ad3ae66e6793719b98 (diff)
downloadports-54e279cd729c9bf5428e3d8423fec99fa7e97b8d.tar.gz
ports-54e279cd729c9bf5428e3d8423fec99fa7e97b8d.zip
Make 41 Go ports respect MAKE_ENV. This is expected to unbreak them.
Ports: benchmarks/hey benchmarks/vegeta databases/influxdb devel/arduino-builder devel/arduinoOTA devel/awless devel/git-codereview devel/git-town devel/gitlab-runner devel/grv devel/hub devel/jfrog-cli editors/micro finance/fixc misc/exercism net-mgmt/intel-snap net-mgmt/kapacitor net-mgmt/telegraf net/goreplay net/syncthing net/syncthing-cli net/syncthing-discosrv net/syncthing-inotify print/cups-connector security/sops security/vault sysutils/amazon-ssm-agent sysutils/circonus-agent sysutils/consul sysutils/consul_exporter sysutils/envconsul sysutils/serf textproc/consul-template textproc/spiff www/gobuffalo www/grafana2 www/grafana3 www/mattermost-server www/minio www/minio-client www/uchiwa Approved by: tcberner (mentor, implicit) Approved by: portmgr (port compliance, infrastructure)
Notes
Notes: svn path=/head/; revision=463776
Diffstat (limited to 'www')
-rw-r--r--www/gobuffalo/Makefile2
-rw-r--r--www/grafana2/Makefile4
-rw-r--r--www/grafana3/Makefile2
-rw-r--r--www/mattermost-server/Makefile2
-rw-r--r--www/minio-client/Makefile2
-rw-r--r--www/minio/Makefile2
-rw-r--r--www/uchiwa/Makefile2
7 files changed, 8 insertions, 8 deletions
diff --git a/www/gobuffalo/Makefile b/www/gobuffalo/Makefile
index 07f8f18f1299..ace9465dea66 100644
--- a/www/gobuffalo/Makefile
+++ b/www/gobuffalo/Makefile
@@ -82,7 +82,7 @@ GH_SUBDIR= src/github.com/gobuffalo/buffalo
PLIST_FILES= bin/buffalo
do-build:
- @cd ${WRKSRC}/${GH_SUBDIR}/buffalo ; ${SETENV} GOPATH=${WRKSRC} go build
+ @cd ${WRKSRC}/${GH_SUBDIR}/buffalo ; ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go build
post-build:
@${STRIP_CMD} ${WRKSRC}/${GH_SUBDIR}/buffalo/buffalo
diff --git a/www/grafana2/Makefile b/www/grafana2/Makefile
index 02a3d0c1595c..6d01bcf8676f 100644
--- a/www/grafana2/Makefile
+++ b/www/grafana2/Makefile
@@ -81,8 +81,8 @@ post-extract:
${RM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/public/app/._.DS_Store
do-build:
- cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
+ @cd ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}; \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${PORTNAME}/${PORTNAME}/bin/grafana-server \
diff --git a/www/grafana3/Makefile b/www/grafana3/Makefile
index e8e027be08b4..99001128c5b3 100644
--- a/www/grafana3/Makefile
+++ b/www/grafana3/Makefile
@@ -116,7 +116,7 @@ post-extract:
do-build:
cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/grafana; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go run build.go build
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/grafana/grafana/bin/grafana-server \
diff --git a/www/mattermost-server/Makefile b/www/mattermost-server/Makefile
index c952fddd3866..d2925619c702 100644
--- a/www/mattermost-server/Makefile
+++ b/www/mattermost-server/Makefile
@@ -43,7 +43,7 @@ pre-build:
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${GH_PROJECT} && \
- ${SETENV} GOPATH=${WRKSRC} go install -ldflags="${GO_LDFLAGS}" ./...
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install -ldflags="${GO_LDFLAGS}" ./...
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/platform ${STAGEDIR}${PREFIX}/bin/mattermostd
diff --git a/www/minio-client/Makefile b/www/minio-client/Makefile
index e7565d5dd86f..52051e306cae 100644
--- a/www/minio-client/Makefile
+++ b/www/minio-client/Makefile
@@ -35,7 +35,7 @@ PLIST_FILES= bin/${MC}
do-build:
@cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${GH_PROJECT}; \
- ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
+ ${SETENV} ${MAKE_ENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build -v -x \
-ldflags "-X main.GitDescribe=v${PORTVERSION}" -o bin/${MC}
do-install:
diff --git a/www/minio/Makefile b/www/minio/Makefile
index 22abf2495f6c..3751469ce784 100644
--- a/www/minio/Makefile
+++ b/www/minio/Makefile
@@ -30,7 +30,7 @@ SUB_LIST= USER="${USERS}" \
do-build:
@cd ${WRKSRC}/${GH_SUBDIR} ; \
- ${SETENV} GOPATH=${WRKSRC} CGO_ENABLED=0 go build \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} CGO_ENABLED=0 go build \
--ldflags '-X github.com/minio/minio/cmd.Version=${GH_TAGNAME:C/RELEASE\.//:C|(..)-(..)-(..)Z|\1:\2:\3Z|} -X github.com/minio/minio/cmd.ReleaseTag=${GH_TAGNAME} -X github.com/minio/minio/cmd.CommitID=${COMMIT_ID} -X github.com/minio/minio/cmd.GOPATH=${WRKSRC} -s -w' -o ${WRKSRC}/bin/minio
do-install:
diff --git a/www/uchiwa/Makefile b/www/uchiwa/Makefile
index 6d2a7588edc7..8d05d631d378 100644
--- a/www/uchiwa/Makefile
+++ b/www/uchiwa/Makefile
@@ -56,7 +56,7 @@ post-extract:
.endfor
do-build:
- @cd ${WRKSRC}/src/github.com/sensu && ${SETENV} GOPATH=${WRKSRC} go install ./...
+ @cd ${WRKSRC}/src/github.com/sensu && ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
do-install:
${MKDIR} ${STAGEDIR}${UCHIWA_LOGDIR} \