aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-02-29 22:43:04 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-02-29 22:43:04 +0000
commit77883cae0b242cea0b457fd750dd0cea8b1fcfe6 (patch)
tree2ab33716f00dbe3bb470f7b8706e467930a89417 /www
parent01766c4f7307f67e892a4625b38b5cbea1927e74 (diff)
downloadports-77883cae0b242cea0b457fd750dd0cea8b1fcfe6.tar.gz
ports-77883cae0b242cea0b457fd750dd0cea8b1fcfe6.zip
www/mod_http2-devel: Apache HTTP/2 module
This is the early experience version of the Apache HTTP/2 module for people who like living on the edge and want to test not yet released changes. Reviewed by: feld (mentor) Approved by: feld (mentor) Differential Revision: D5220
Notes
Notes: svn path=/head/; revision=409831
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_http2-devel/Makefile40
-rw-r--r--www/mod_http2-devel/distinfo2
-rw-r--r--www/mod_http2-devel/pkg-descr4
-rw-r--r--www/mod_http2-devel/pkg-message14
-rw-r--r--www/mod_http2-devel/pkg-plist2
6 files changed, 63 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 6b20bb0b4380..d85073034c5a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -468,6 +468,7 @@
SUBDIR += mod_flickr
SUBDIR += mod_geoip2
SUBDIR += mod_gzip2
+ SUBDIR += mod_http2-devel
SUBDIR += mod_h264_streaming
SUBDIR += mod_hosts_access
SUBDIR += mod_jail
diff --git a/www/mod_http2-devel/Makefile b/www/mod_http2-devel/Makefile
new file mode 100644
index 000000000000..1aa77701afc4
--- /dev/null
+++ b/www/mod_http2-devel/Makefile
@@ -0,0 +1,40 @@
+# Created by: Bernard Spil <brnrd@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mod_http2-devel
+PORTVERSION= 1.2.7
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+
+MAINTAINER= brnrd@FreeBSD.org
+COMMENT= Early experience HTTP/2 module for Apache httpd
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= nghttp2>=1.2:${PORTSDIR}/www/nghttp2
+LIB_DEPENDS= libnghttp2.so:${PORTSDIR}/www/nghttp2
+
+USE_GITHUB= yes
+GH_ACCOUNT= icing
+GH_PROJECT= mod_h2
+
+USES= autoreconf libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=ext-
+CONFIGURE_ENV= CONFIG_SHELL=/bin/sh
+
+USE_APACHE= 24+
+MODULENAME= ${GH_PROJECT}
+
+CFLAGS+= -I${LOCALBASE}/include
+
+post-install:
+ # Rename mod_http2 to the mod_h2 to avoid conflict with Apache24
+ ${MV} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_http2.so.0.0.0 \
+ ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+ ${RM} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/mod_http2.so
+ ${MV} ${STAGEDIR}${PORTDOCS}${PREFIX}/share/doc/mod_http2 \
+ ${STAGEDIR}${PORTDOCS}${DOCSDIR}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}/${MODULENAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_http2-devel/distinfo b/www/mod_http2-devel/distinfo
new file mode 100644
index 000000000000..1a7272c80986
--- /dev/null
+++ b/www/mod_http2-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (icing-mod_h2-v1.2.7_GH0.tar.gz) = 165b03a506be640584a297cdeb09b8c9355f9362910a9c7086f65cb583333c18
+SIZE (icing-mod_h2-v1.2.7_GH0.tar.gz) = 139292
diff --git a/www/mod_http2-devel/pkg-descr b/www/mod_http2-devel/pkg-descr
new file mode 100644
index 000000000000..773dd9bfe8c0
--- /dev/null
+++ b/www/mod_http2-devel/pkg-descr
@@ -0,0 +1,4 @@
+This Apache module supports the "h2" (HTTP2 over TLS) and "h2c" (HTTP2
+over plain HTTP connections via Upgrade). You can enable it for the
+whole server or for specific virtual hosts only. More on this below on
+"Configuration".
diff --git a/www/mod_http2-devel/pkg-message b/www/mod_http2-devel/pkg-message
new file mode 100644
index 000000000000..26a38c4532d0
--- /dev/null
+++ b/www/mod_http2-devel/pkg-message
@@ -0,0 +1,14 @@
+If you want to have the h2 module enabled in your apache installation,
+you need to add
+
+ LoadModule http2_module modules/mod_h2.so
+
+somewhere in your config files and add a line like
+
+ H2Engine on
+
+whereever you want the module to be active (general server of specific
+virtual hosts).
+
+NB: The shared libraries were renamed from mod_http2 to mod_h2 to
+ avoid conflicts with the (now bundled) mod_http2 in www/apache24
diff --git a/www/mod_http2-devel/pkg-plist b/www/mod_http2-devel/pkg-plist
new file mode 100644
index 000000000000..80f3e93b58d0
--- /dev/null
+++ b/www/mod_http2-devel/pkg-plist
@@ -0,0 +1,2 @@
+%%APACHEMODDIR%%/%%AP_MODULE%%
+%%PORTDOCS%%%%DOCSDIR%%/README