aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJochen Neumeister <joneum@FreeBSD.org>2023-01-30 07:59:50 +0000
committerJochen Neumeister <joneum@FreeBSD.org>2023-01-30 08:01:57 +0000
commitd0c4f648b9c68d9b845cc2b7df1212d66dd9d737 (patch)
tree10c0e550eb907a61dcb9b07ac1f9e45bd56d6d83 /www
parent23944a5d765f9206dd8f9fd81f320066cdf63540 (diff)
downloadports-d0c4f648b9c68d9b845cc2b7df1212d66dd9d737.tar.gz
ports-d0c4f648b9c68d9b845cc2b7df1212d66dd9d737.zip
www/nginx: fix dependences for some modules
HTTP_DAV_EXT module requires libraries, so let's define them with a more canonical way. While I'm here use the same way to define dependences for the HTTP_XSLT module as well. PR: 261134 Sponsored by: Netzkommune GmbH
Diffstat (limited to 'www')
-rw-r--r--www/nginx/Makefile6
-rw-r--r--www/nginx/Makefile.extmod3
2 files changed, 5 insertions, 4 deletions
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 0b08c5cf37aa..1b95142c4658 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -1,6 +1,6 @@
PORTNAME= nginx
PORTVERSION= 1.22.1
-PORTREVISION?= 2
+PORTREVISION?= 3
PORTEPOCH= 3
CATEGORIES= www
MASTER_SITES= https://nginx.org/download/ \
@@ -164,8 +164,8 @@ HTTP_SSL_CONFIGURE_ON= --with-http_ssl_module
HTTP_SSL_USES= ssl
HTTP_STATUS_CONFIGURE_ON= --with-http_stub_status_module
HTTP_SUB_CONFIGURE_ON= --with-http_sub_module
-HTTP_XSLT_USES= gnome
-HTTP_XSLT_USE= GNOME=libxml2,libxslt
+HTTP_XSLT_LIB_DEPENDS= libxml2.so:textproc/libxml2 \
+ libxslt.so:textproc/libxslt
HTTP_XSLT_VARS= DSO_BASEMODS+=http_xslt_module
HTTPV2_IMPLIES= HTTP_SSL
HTTPV2_CONFIGURE_ON= --with-http_v2_module
diff --git a/www/nginx/Makefile.extmod b/www/nginx/Makefile.extmod
index fa7472f5823f..9f4bb82416cd 100644
--- a/www/nginx/Makefile.extmod
+++ b/www/nginx/Makefile.extmod
@@ -90,7 +90,8 @@ HTTP_AUTH_PAM_GH_TUPLE= sto:ngx_http_auth_pam_module:v1.5.1:auth_pam
HTTP_AUTH_PAM_VARS= DSO_EXTMODS+=auth_pam
HTTP_DAV_EXT_IMPLIES= HTTP_DAV
-HTTP_DAV_EXT_LIB_DEPENDS= libexpat.so:textproc/expat2
+HTTP_DAV_EXT_LIB_DEPENDS= libxml2.so:textproc/libxml2 \
+ libxslt.so:textproc/libxslt
HTTP_DAV_EXT_GH_TUPLE= arut:nginx-dav-ext-module:v3.0.0:dav_ext
HTTP_DAV_EXT_VARS= DSO_EXTMODS+=dav_ext
HTTP_DAV_EXT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ngx_http_dav_ext_module.c