aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/fvwm3/Makefile
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-31 12:13:22 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-31 16:37:21 +0000
commitd5f33570094ca4777eb4a906214f2465961a712b (patch)
tree475e9c8909d6aa9ce435a3ff1b3239894ac8e6e2 /x11-wm/fvwm3/Makefile
parentce15103bd7cc3e3f437d5164523f6977b88c4ad7 (diff)
x11-wm/fvwm3: Add .desktop entry for XSession
Add a .desktop file of type XSession, so fvwm3 is discoverable for display managers following freedesktop.org standards. PR: 272836 Co-authored-by: Bartek Jasicki <thindil@laeran.pl.eu.org>
Diffstat (limited to 'x11-wm/fvwm3/Makefile')
-rw-r--r--x11-wm/fvwm3/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-wm/fvwm3/Makefile b/x11-wm/fvwm3/Makefile
index accd089a2535..77f8ed3a7142 100644
--- a/x11-wm/fvwm3/Makefile
+++ b/x11-wm/fvwm3/Makefile
@@ -1,6 +1,6 @@
PORTNAME= fvwm3
DISTVERSION= 1.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-wm
MASTER_SITES= https://github.com/fvwmorg/fvwm3/releases/download/${DISTVERSION}/ \
http://fvwm.sourceforge.net/generated/icon_download/:icons
@@ -25,6 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= ac_cv_path_PYTHON=${PYTHON_CMD}
CONFLICTS_INSTALL= fvwm
+SUB_FILES= fvwm3.desktop
PLIST_SUB= DISTVERSION=${DISTVERSION}
OPTIONS_DEFINE= FRIBIDI GO ICONS ICONV MANPAGES NLS PERL PNG SVG \
@@ -74,6 +75,11 @@ post-patch:
@${REINPLACE_CMD} -e 's,/etc/,${LOCALBASE}/etc/,g' \
${WRKSRC}/bin/fvwm-menu-desktop.in
+post-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/xsessions
+ ${INSTALL_DATA} ${WRKDIR}/fvwm3.desktop \
+ ${STAGEDIR}${PREFIX}/share/xsessions
+
post-install-ICONS-on:
${MKDIR} ${STAGEDIR}${PREFIX}/share/fvwm3/pixmaps
${INSTALL_DATA} ${WRKDIR}/${FVWM_ICONS}/*.xpm \