aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/sawfish
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-12-26 15:23:35 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-12-26 18:41:44 +0000
commit61848c0c8b870a8bb5e75637308bcf6cc7d87dc9 (patch)
tree7fef036c07519f122de96dac3b8d46464f78fd27 /x11-wm/sawfish
parentb7a6b250ed8795e43c7c0efc4c3708093aff8c34 (diff)
downloadports-61848c0c8b870a8bb5e75637308bcf6cc7d87dc9.tar.gz
ports-61848c0c8b870a8bb5e75637308bcf6cc7d87dc9.zip
x11-wm/sawfish: update to 1.13.0
* Add missing dependencies * Remove merged patch. * Remove noop REINPLACE_CMD Reported by: portscout
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/Makefile14
-rw-r--r--x11-wm/sawfish/distinfo6
-rw-r--r--x11-wm/sawfish/files/patch-d4364707.c88
-rw-r--r--x11-wm/sawfish/pkg-plist4
4 files changed, 10 insertions, 102 deletions
diff --git a/x11-wm/sawfish/Makefile b/x11-wm/sawfish/Makefile
index bb5bcf56f3d3..a25a299be471 100644
--- a/x11-wm/sawfish/Makefile
+++ b/x11-wm/sawfish/Makefile
@@ -1,7 +1,7 @@
# Created by: Yukihiro Nakai <nakai@FreeBSD.org>
PORTNAME= sawfish
-DISTVERSION= 1.12.90
+DISTVERSION= 1.13.0
CATEGORIES= x11-wm
MASTER_SITES= http://download.tuxfamily.org/sawfish/
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -13,16 +13,18 @@ LICENSE= ART20 GPLv2
LICENSE_COMB= multi
BUILD_DEPENDS= rep-gtk2>=0.90:x11-toolkits/rep-gtk2
-LIB_DEPENDS= librep.so:lang/librep \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libgmp.so:math/gmp \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libharfbuzz.so:print/harfbuzz \
+ librep.so:lang/librep
+
RUN_DEPENDS= rep-gtk2>=0.90:x11-toolkits/rep-gtk2
USES= autoreconf gmake gnome libtool localbase makeinfo pathfix \
pkgconfig tar:xz xorg
USE_XORG= ice sm x11 xft xinerama xrandr xtst xrender xext
-USE_GNOME= cairo gtk20
+USE_GNOME= cairo gdkpixbuf2 gtk20
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share \
--datadir=${PREFIX}/share
@@ -42,8 +44,6 @@ post-patch:
@${REINPLACE_CMD} -e \
'/dnsdomainname/d' ${WRKSRC}/build-info
@${REINPLACE_CMD} -e \
- '/KDEDIR/s|^|#|g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e \
's|prog_name|program_name|g' ${WRKSRC}/src/main.c
post-build:
diff --git a/x11-wm/sawfish/distinfo b/x11-wm/sawfish/distinfo
index b67c2d7063f1..66d95783c667 100644
--- a/x11-wm/sawfish/distinfo
+++ b/x11-wm/sawfish/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566752091
-SHA256 (sawfish_1.12.90.tar.xz) = 6154151312d99c97d0a61f83a0dd2630e427bebb1ae2119e7372278971d6e8a2
-SIZE (sawfish_1.12.90.tar.xz) = 2602372
+TIMESTAMP = 1640532189
+SHA256 (sawfish_1.13.0.tar.xz) = 816b3c5bfa4cb508db1fc14489fccd023dec899cf13ddeb19bc3e65d7872af5d
+SIZE (sawfish_1.13.0.tar.xz) = 2830924
diff --git a/x11-wm/sawfish/files/patch-d4364707.c b/x11-wm/sawfish/files/patch-d4364707.c
deleted file mode 100644
index f6ba723779bd..000000000000
--- a/x11-wm/sawfish/files/patch-d4364707.c
+++ /dev/null
@@ -1,88 +0,0 @@
-diff --git a/src/flippers.c b/src/flippers.c
-index c18efcf3..1b248e68 100644
---- src/flippers.c
-+++ src/flippers.c
-@@ -22,10 +22,6 @@
-
- static Window edge_left, edge_right, edge_top, edge_bottom;
-
--DEFSYM(left, "left");
--DEFSYM(right, "right");
--DEFSYM(top, "top");
--DEFSYM(bottom, "bottom");
- DEFSYM(enter_flipper_hook, "enter-flipper-hook");
- DEFSYM(leave_flipper_hook, "leave-flipper-hook");
-
-@@ -155,10 +151,6 @@ flippers_init (void)
-
- rep_pop_structure (tem);
-
-- rep_INTERN (left);
-- rep_INTERN (right);
-- rep_INTERN (top);
-- rep_INTERN (bottom);
- rep_INTERN_SPECIAL (enter_flipper_hook);
- rep_INTERN_SPECIAL (leave_flipper_hook);
- Fset(Qenter_flipper_hook, Qnil);
-diff --git a/src/functions.c b/src/functions.c
-index ff797529..7b191151 100644
---- src/functions.c
-+++ src/functions.c
-@@ -65,7 +65,6 @@ static int xinerama_heads;
- # endif
- #endif
-
--DEFSYM(root, "root");
- DEFSYM(after_restacking_hook, "after-restacking-hook");
- DEFSYM(position, "position");
- DEFSYM(spacing, "spacing");
-@@ -1406,7 +1405,6 @@ functions_init (void)
- rep_ADD_SUBR(Ssend_client_message);
- rep_pop_structure (tem);
-
-- rep_INTERN(root);
- rep_INTERN_SPECIAL(after_restacking_hook);
- Fset(Qafter_restacking_hook, Qnil);
- rep_INTERN(position);
-diff --git a/src/sawfish_subrs.h b/src/sawfish_subrs.h
-index 8b1e7a2c..e2256249 100644
---- src/sawfish_subrs.h
-+++ src/sawfish_subrs.h
-@@ -79,7 +79,7 @@ extern void (*event_handlers[LASTEvent])(XEvent *ev);
- extern Time last_event_time;
- extern XEvent *current_x_event;
- extern repv Qvisibility_notify_hook, Qdestroy_notify_hook, Qmap_notify_hook,
-- Qunmap_notify_hook, Qreparent_notify_hook, Qenter_notify_hook,
-+ Qunmap_notify_hook, Qreparent_notify_hook, Qenter_notify_hook, Qroot,
- Qleave_notify_hook, Qfocus_in_hook, Qfocus_out_hook, Qclient_message_hook,
- Qwindow_moved_hook, Qwindow_resized_hook, Qrandr_change_notify_hook;
- extern repv Qiconify_window, Quniconify_window;
-@@ -158,7 +158,7 @@ extern void frames_init (void);
- extern void frames_kill (void);
-
- /* from functions.c */
--extern repv Qroot, Qafter_restacking_hook, Qposition, Qspacing;
-+extern repv Qafter_restacking_hook, Qposition, Qspacing;
- extern repv Fdelete_window (repv win);
- extern repv Fdestroy_window (repv win);
- extern repv Frestack_windows (repv list);
-diff --git a/src/windows.c b/src/windows.c
-index eef835bd..c1cf652f 100644
---- src/windows.c
-+++ src/windows.c
-@@ -75,7 +75,6 @@ DEFSYM(north_west, "north-west");
- DEFSYM(north, "north");
- DEFSYM(north_east, "north-east");
- DEFSYM(west, "west");
--DEFSYM(center, "center");
- DEFSYM(east, "east");
- DEFSYM(south_west, "south-west");
- DEFSYM(south, "south");
-@@ -1845,7 +1844,6 @@ windows_init (void)
- rep_INTERN(north);
- rep_INTERN(north_east);
- rep_INTERN(west);
-- rep_INTERN(center);
- rep_INTERN(east);
- rep_INTERN(south_west);
- rep_INTERN(south);
diff --git a/x11-wm/sawfish/pkg-plist b/x11-wm/sawfish/pkg-plist
index 1c5b6182f376..b540d2ad8866 100644
--- a/x11-wm/sawfish/pkg-plist
+++ b/x11-wm/sawfish/pkg-plist
@@ -179,8 +179,6 @@ share/ksmserver/windowmanagers/sawfish.desktop
%%DATADIR%%/lisp/poweroff.jlc
%%DATADIR%%/lisp/prompt.jl
%%DATADIR%%/lisp/prompt.jlc
-%%DATADIR%%/lisp/razor-int.jl
-%%DATADIR%%/lisp/razor-int.jlc
%%DATADIR%%/lisp/rects.jl
%%DATADIR%%/lisp/rects.jlc
%%DATADIR%%/lisp/sawfish/cfg/apply.jl
@@ -358,8 +356,6 @@ share/ksmserver/windowmanagers/sawfish.desktop
%%DATADIR%%/lisp/sawfish/wm/integration/lxde.jlc
%%DATADIR%%/lisp/sawfish/wm/integration/mate.jl
%%DATADIR%%/lisp/sawfish/wm/integration/mate.jlc
-%%DATADIR%%/lisp/sawfish/wm/integration/razor.jl
-%%DATADIR%%/lisp/sawfish/wm/integration/razor.jlc
%%DATADIR%%/lisp/sawfish/wm/integration/xfce.jl
%%DATADIR%%/lisp/sawfish/wm/integration/xfce.jlc
%%DATADIR%%/lisp/sawfish/wm/keymaps.jl