aboutsummaryrefslogtreecommitdiff
path: root/x11/xstroke
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-03-30 06:48:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-03-30 06:48:08 +0000
commit9548120fa746e83fe3f90a0b24fe83a5ef2f4125 (patch)
tree8e8ba5b73e50b1d908d5d87675a7555ef234044c /x11/xstroke
parent7f023fbfdc7bc07e030a67616a16e691cdf245d5 (diff)
downloadports-9548120fa746e83fe3f90a0b24fe83a5ef2f4125.tar.gz
ports-9548120fa746e83fe3f90a0b24fe83a5ef2f4125.zip
revert r412141
On FreeBSD 9 the dependency syntax used here will use the "old yacc" which is in in base and not byacc from ports which does not support %pure_parser. Dropping bison as a build dependency is not worth a more complex syntax
Notes
Notes: svn path=/head/; revision=412157
Diffstat (limited to 'x11/xstroke')
-rw-r--r--x11/xstroke/Makefile3
-rw-r--r--x11/xstroke/files/patch-Imakefile2
2 files changed, 2 insertions, 3 deletions
diff --git a/x11/xstroke/Makefile b/x11/xstroke/Makefile
index b9690bd143b2..53252c5dce60 100644
--- a/x11/xstroke/Makefile
+++ b/x11/xstroke/Makefile
@@ -13,8 +13,7 @@ COMMENT= Fullscreen gesture recognition
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-USES= imake
-BUILD_DEPENDS= byacc:devel/byacc
+USES= bison imake
USE_XORG= xft x11 xext xi xtst
PLIST_FILES= bin/xstroke %%ETCDIR%%/alphabet man/man1/xstroke.1.gz
diff --git a/x11/xstroke/files/patch-Imakefile b/x11/xstroke/files/patch-Imakefile
index ed0491b879b4..8c632e41a45f 100644
--- a/x11/xstroke/files/patch-Imakefile
+++ b/x11/xstroke/files/patch-Imakefile
@@ -9,7 +9,7 @@
-LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm -ldl -lpthread
+LOCAL_LIBRARIES=$(XTESTLIB) $(XLIB) $(XRENDERLIB) $(XFTLIB) -lm $(LDFLAGS)
FLEX=flex
-+YACC=byacc
++YACC=bison -y
OBJS=xstroke.o args.o backing.o bresenham.o brush.o control_win.o stroke.o matrix.o \
action.o action_item.o feature.o gesture.o log.o option.o sprintf_alloc.o \
rec.o rec_callback.o rec_history.o rec_lex.o rec_mode.o rec_parse.o \