aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/R-cran-rvest/Makefile21
-rw-r--r--www/R-cran-rvest/distinfo2
-rw-r--r--www/R-cran-rvest/pkg-descr4
4 files changed, 28 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 48ff66d6125e..63959d4a35b2 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -9,6 +9,7 @@
SUBDIR += R-cran-htmlwidgets
SUBDIR += R-cran-httpuv
SUBDIR += R-cran-httr
+ SUBDIR += R-cran-rvest
SUBDIR += R-cran-scrapeR
SUBDIR += R-cran-selectr
SUBDIR += R-cran-shiny
diff --git a/www/R-cran-rvest/Makefile b/www/R-cran-rvest/Makefile
new file mode 100644
index 000000000000..ec9b828010b3
--- /dev/null
+++ b/www/R-cran-rvest/Makefile
@@ -0,0 +1,21 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rvest
+PORTVERSION= 0.2.0
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Easily Harvest (Scrape) Web Pages
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= R-cran-httr>=0.5:${PORTSDIR}/www/R-cran-httr \
+ R-cran-XML>0:${PORTSDIR}/textproc/R-cran-XML \
+ R-cran-selectr>0:${PORTSDIR}/www/R-cran-selectr \
+ R-cran-magrittr>0:${PORTSDIR}/devel/R-cran-magrittr
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/www/R-cran-rvest/distinfo b/www/R-cran-rvest/distinfo
new file mode 100644
index 000000000000..9a4d8bc0ab76
--- /dev/null
+++ b/www/R-cran-rvest/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rvest_0.2.0.tar.gz) = 275a6e0aca14c4ac713a0051bd0bda5b4e3806361a51a66e3eba27f839a0e9ad
+SIZE (rvest_0.2.0.tar.gz) = 5407840
diff --git a/www/R-cran-rvest/pkg-descr b/www/R-cran-rvest/pkg-descr
new file mode 100644
index 000000000000..118c44b3a51c
--- /dev/null
+++ b/www/R-cran-rvest/pkg-descr
@@ -0,0 +1,4 @@
+Wrappers around the XML and httr packages to make it easy to download,
+then manipulate, both html and xml.
+
+WWW: https://cran.r-project.org/web/packages/rvest/