aboutsummaryrefslogtreecommitdiff
path: root/www/R-cran-rvest/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/R-cran-rvest/Makefile')
-rw-r--r--www/R-cran-rvest/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/R-cran-rvest/Makefile b/www/R-cran-rvest/Makefile
new file mode 100644
index 000000000000..ec9b828010b3
--- /dev/null
+++ b/www/R-cran-rvest/Makefile
@@ -0,0 +1,21 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rvest
+PORTVERSION= 0.2.0
+CATEGORIES= www
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Easily Harvest (Scrape) Web Pages
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= R-cran-httr>=0.5:${PORTSDIR}/www/R-cran-httr \
+ R-cran-XML>0:${PORTSDIR}/textproc/R-cran-XML \
+ R-cran-selectr>0:${PORTSDIR}/www/R-cran-selectr \
+ R-cran-magrittr>0:${PORTSDIR}/devel/R-cran-magrittr
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>