aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-URI-Match/Makefile25
-rw-r--r--net/p5-URI-Match/distinfo2
-rw-r--r--net/p5-URI-Match/pkg-descr13
-rw-r--r--net/p5-URI-Match/pkg-plist3
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 171f30f5c50e..68fa316594db 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -727,6 +727,7 @@
SUBDIR += p5-Test-URI
SUBDIR += p5-URI
SUBDIR += p5-URI-FromHash
+ SUBDIR += p5-URI-Match
SUBDIR += p5-URI-OpenURL
SUBDIR += p5-URI-SmartURI
SUBDIR += p5-URI-Template
diff --git a/net/p5-URI-Match/Makefile b/net/p5-URI-Match/Makefile
new file mode 100644
index 000000000000..0c73a641fe57
--- /dev/null
+++ b/net/p5-URI-Match/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: URI::Match
+# Date created: 09 Sep 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Match
+PORTVERSION= 0.00001
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for matching URLs by parts
+
+RUN_DEPENDS= \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::Match.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-Match/distinfo b/net/p5-URI-Match/distinfo
new file mode 100644
index 000000000000..baafc70b1118
--- /dev/null
+++ b/net/p5-URI-Match/distinfo
@@ -0,0 +1,2 @@
+SHA256 (URI-Match-0.00001.tar.gz) = 80be56c6591b6a17b8217cf9c03ba910d6ab0537d7a01c43dccc6bf7e567ca84
+SIZE (URI-Match-0.00001.tar.gz) = 13163
diff --git a/net/p5-URI-Match/pkg-descr b/net/p5-URI-Match/pkg-descr
new file mode 100644
index 000000000000..57883ed6d299
--- /dev/null
+++ b/net/p5-URI-Match/pkg-descr
@@ -0,0 +1,13 @@
+This is a simple utility that adds ability to match URL parts against
+regular expressions, subroutines, or objects that implement a match()
+method.
+
+Since this module uses loops and method calls, writing up a clever
+regular expression and using it directly against the whole URL is
+probably faster. This module aims to solve the problem where
+readability matters, or when you need to assemble the match conditions
+at run time.
+
+URI::Match adds the following methods to the URI namespace.
+
+WWW: http://search.cpan.org/dist/URI-Match/
diff --git a/net/p5-URI-Match/pkg-plist b/net/p5-URI-Match/pkg-plist
new file mode 100644
index 000000000000..7cebd168acb7
--- /dev/null
+++ b/net/p5-URI-Match/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Match/.packlist
+%%SITE_PERL%%/URI/Match.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Match