aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/eris/Makefile14
-rw-r--r--devel/mercator/Makefile11
-rw-r--r--devel/mercator/distinfo4
-rw-r--r--devel/mercator/files/patch-Merecator-iround.h19
-rw-r--r--devel/mercator/pkg-plist2
5 files changed, 18 insertions, 32 deletions
diff --git a/devel/eris/Makefile b/devel/eris/Makefile
index ba62dc6e0eac..5396eb83712b 100644
--- a/devel/eris/Makefile
+++ b/devel/eris/Makefile
@@ -10,19 +10,19 @@ MASTER_SITES= SF/worldforge/Eris%201.4%20%28client%20lib%29/${PORTVERSION}/
MAINTAINER= oliver@FreeBSD.org
COMMENT= WorldForge client entity library
-LIB_DEPENDS= Atlas-0.6.2:${PORTSDIR}/devel/atlas-devel \
- skstream-0.3.7:${PORTSDIR}/net/skstream \
- wfmath-1.0.1:${PORTSDIR}/math/wfmath \
- sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- mercator-0.3.3:${PORTSDIR}/devel/mercator
+LIB_DEPENDS= libAtlas-0.6.so:${PORTSDIR}/devel/atlas-devel \
+ libskstream-0.3.so:${PORTSDIR}/net/skstream \
+ libwfmath-1.0.so:${PORTSDIR}/math/wfmath \
+ libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ libmercator-0.3.so:${PORTSDIR}/devel/mercator
+CONFIGURE_ARGS= --disable-silent-rules
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig
USE_GCC= yes
CXXFLAGS+= -include wchar.h
-CONFIGURE_ARGS+="CXXFLAGS=${CXXFLAGS}"
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/mercator/Makefile b/devel/mercator/Makefile
index 78faf9f4a9ad..66b80b77b6b8 100644
--- a/devel/mercator/Makefile
+++ b/devel/mercator/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= mercator
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.3.3
+#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/worldforge/Mercator%20%28terrain%20lib%29/${PORTVERSION}
@@ -12,11 +12,16 @@ COMMENT= A procedural terrain library
LIB_DEPENDS= libwfmath-1.0.so:${PORTSDIR}/math/wfmath
-USES= pathfix pkgconfig
+CONFIGURE_ARGS= --disable-silent-rules
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GCC= yes
+USE_GCC= 4.7+
CXXFLAGS+= -include wchar.h
+post-patch:
+ @${REINPLACE_CMD} -e 's|std::lround|lround|g' ${WRKSRC}/Mercator/iround.h
+
.include <bsd.port.mk>
diff --git a/devel/mercator/distinfo b/devel/mercator/distinfo
index 1f4fe52774eb..ecfddc8cab16 100644
--- a/devel/mercator/distinfo
+++ b/devel/mercator/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mercator-0.3.2.tar.gz) = 5388299694545b266d0c232fc7124ec52d88fef69159b0acd38919fd1095fcc1
-SIZE (mercator-0.3.2.tar.gz) = 432442
+SHA256 (mercator-0.3.3.tar.gz) = 04c71d780979a2b43835b8b30879b39c4d7688661dab8e2bf7046ef9e7aff1e9
+SIZE (mercator-0.3.3.tar.gz) = 436499
diff --git a/devel/mercator/files/patch-Merecator-iround.h b/devel/mercator/files/patch-Merecator-iround.h
deleted file mode 100644
index 1bac80e786a9..000000000000
--- a/devel/mercator/files/patch-Merecator-iround.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- Mercator/iround.h.orig Tue Oct 4 01:25:06 2005
-+++ Mercator/iround.h Tue Oct 4 01:31:36 2005
-@@ -9,6 +9,16 @@
- #error iround.h must be included after config.h
- #endif
-
-+#if defined(__FreeBSD__)
-+#include <osreldate.h>
-+#if __FreeBSD_version < 500000
-+extern "C" {
-+extern float fabsf __P((float));
-+extern float rintf __P((float));
-+}
-+#endif
-+#endif
-+
- #ifdef HAVE_LRINTF
- #define I_ROUND(x) (::lrintf(x))
- #elif defined(HAVE_RINTF)
diff --git a/devel/mercator/pkg-plist b/devel/mercator/pkg-plist
index bcdf59ce23bc..4fc630c3fd66 100644
--- a/devel/mercator/pkg-plist
+++ b/devel/mercator/pkg-plist
@@ -1,6 +1,6 @@
lib/libmercator-0.3.la
lib/libmercator-0.3.so
-lib/libmercator-0.3.so.3
+lib/libmercator-0.3.so.4
include/Mercator-0.3/Mercator/Effector.h
include/Mercator-0.3/Mercator/Mercator.h
include/Mercator-0.3/Mercator/Matrix.h