aboutsummaryrefslogtreecommitdiff
path: root/devel/mercator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/mercator/Makefile')
-rw-r--r--devel/mercator/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/mercator/Makefile b/devel/mercator/Makefile
index 78faf9f4a9ad..66b80b77b6b8 100644
--- a/devel/mercator/Makefile
+++ b/devel/mercator/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= mercator
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.3.3
+#PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/worldforge/Mercator%20%28terrain%20lib%29/${PORTVERSION}
@@ -12,11 +12,16 @@ COMMENT= A procedural terrain library
LIB_DEPENDS= libwfmath-1.0.so:${PORTSDIR}/math/wfmath
-USES= pathfix pkgconfig
+CONFIGURE_ARGS= --disable-silent-rules
+USES= pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GCC= yes
+USE_GCC= 4.7+
CXXFLAGS+= -include wchar.h
+post-patch:
+ @${REINPLACE_CMD} -e 's|std::lround|lround|g' ${WRKSRC}/Mercator/iround.h
+
.include <bsd.port.mk>