aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/see/Makefile3
-rw-r--r--lang/see/files/patch-libsee_dtoa__config.h12
2 files changed, 12 insertions, 3 deletions
diff --git a/lang/see/Makefile b/lang/see/Makefile
index bc7cd72ca56a..a4a6c5be6d36 100644
--- a/lang/see/Makefile
+++ b/lang/see/Makefile
@@ -18,9 +18,6 @@ LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/COPYING
LICENSE_FILE_DTOA.C= ${WRKSRC}/COPYING
LICENSE_PERMS_DTOA.C= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_aarch64= fails to build: error: "Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined."
-BROKEN_riscv64= fails to build: error: "Exactly one of IEEE_8087, IEEE_MC68k, VAX, or IBM should be defined."
-
OPTIONS_DEFINE= GC DEBUG DOCS
OPTIONS_DEFAULT= GC
GC_DESC= Use Boehm-Weiser garbage collection package
diff --git a/lang/see/files/patch-libsee_dtoa__config.h b/lang/see/files/patch-libsee_dtoa__config.h
new file mode 100644
index 000000000000..3dd1dd64d754
--- /dev/null
+++ b/lang/see/files/patch-libsee_dtoa__config.h
@@ -0,0 +1,12 @@
+--- libsee/dtoa_config.h.orig 2022-11-12 15:54:29 UTC
++++ libsee/dtoa_config.h
+@@ -11,7 +11,8 @@
+
+ #include <see/type.h>
+
+-#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__)
++#if defined(__i386__) || defined(__amd64__) || defined(__ia64__) || defined(__alpha__) \
++ || defined(__arm__) || defined(__aarch64__) || defined(__riscv)
+ # define IEEE_8087
+ #endif
+