aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/qt4-sql/Makefile6
-rw-r--r--devel/dbus-qt4/Makefile6
-rw-r--r--devel/qt4-corelib/Makefile6
-rw-r--r--devel/qt4-designer/Makefile9
-rw-r--r--devel/qt4-qt3support/Makefile6
-rw-r--r--devel/qt4-qtestlib/Makefile6
-rw-r--r--graphics/qt4-svg/Makefile6
-rw-r--r--net/qt4-network/Makefile6
-rw-r--r--textproc/qt4-xml/Makefile6
-rw-r--r--x11-toolkits/qt4-gui/Makefile6
-rw-r--r--x11/qt4-opengl/Makefile6
11 files changed, 58 insertions, 11 deletions
diff --git a/databases/qt4-sql/Makefile b/databases/qt4-sql/Makefile
index 626afd0b581d..868eb78b1bdb 100644
--- a/databases/qt4-sql/Makefile
+++ b/databases/qt4-sql/Makefile
@@ -8,7 +8,7 @@
PORTNAME= sql
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= databases
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -77,5 +77,9 @@ post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtSql.pc|${PREFIX}/libdata/pkgconfig/QtSql.pc|g' \
-e 's|(test -z.*||g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/devel/dbus-qt4/Makefile b/devel/dbus-qt4/Makefile
index 3680ed40cb83..ef3ecdbc93d8 100644
--- a/devel/dbus-qt4/Makefile
+++ b/devel/dbus-qt4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dbus
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMESUFFIX= -qt4
@@ -71,5 +71,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtDBus.pc|${PREFIX}/libdata/pkgconfig/QtDBus.pc|g' \
${WRKSRC}/src/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/devel/qt4-corelib/Makefile b/devel/qt4-corelib/Makefile
index f80a80eac79c..412e6a47cd3e 100644
--- a/devel/qt4-corelib/Makefile
+++ b/devel/qt4-corelib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= corelib
PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -78,6 +78,10 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtCore.pc|${PREFIX}/libdata/pkgconfig/QtCore.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.if !defined(PKGNAMESUFFIX)
post-install:
diff --git a/devel/qt4-designer/Makefile b/devel/qt4-designer/Makefile
index 50efbb4a4278..e4b4a3f05feb 100644
--- a/devel/qt4-designer/Makefile
+++ b/devel/qt4-designer/Makefile
@@ -8,7 +8,7 @@
PORTNAME= designer
PORTVERSION= 4.2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -78,4 +78,11 @@ pre-configure:
${LN} -sf ${LOCALBASE}/bin/uic-qt4 ${WRKSRC}/../../bin/uic
${LN} -sf ${LOCALBASE}/bin/rcc ${WRKSRC}/../../bin/rcc
+post-configure:
+ ${REINPLACE_CMD} -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/src/uitools/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
+
.include <bsd.port.post.mk>
diff --git a/devel/qt4-qt3support/Makefile b/devel/qt4-qt3support/Makefile
index 6280e90f6b3b..e4bddbffc32c 100644
--- a/devel/qt4-qt3support/Makefile
+++ b/devel/qt4-qt3support/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qt3support
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= devel x11-toolkits
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -72,5 +72,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/Qt3Support.pc|${PREFIX}/libdata/pkgconfig/Qt3Support.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/devel/qt4-qtestlib/Makefile b/devel/qt4-qtestlib/Makefile
index 460e18d60d09..8c50a64a0485 100644
--- a/devel/qt4-qtestlib/Makefile
+++ b/devel/qt4-qtestlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qtestlib
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= devel
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -68,5 +68,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtTest.pc|${PREFIX}/libdata/pkgconfig/QtTest.pc|g' \
${WRKSRC}/src/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 176410c57c81..dfefecff2de5 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -8,7 +8,7 @@
PORTNAME= svg
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= graphics
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -79,5 +79,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtSvg.pc|${PREFIX}/libdata/pkgconfig/QtSvg.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/net/qt4-network/Makefile b/net/qt4-network/Makefile
index 894e1ddb460a..7c6de1357ba0 100644
--- a/net/qt4-network/Makefile
+++ b/net/qt4-network/Makefile
@@ -8,7 +8,7 @@
PORTNAME= network
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= net ipv6
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -69,5 +69,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtNetwork.pc|${PREFIX}/libdata/pkgconfig/QtNetwork.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/textproc/qt4-xml/Makefile b/textproc/qt4-xml/Makefile
index 1ac9c4f8efe9..9ec5d8787fed 100644
--- a/textproc/qt4-xml/Makefile
+++ b/textproc/qt4-xml/Makefile
@@ -8,7 +8,7 @@
PORTNAME= xml
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= textproc
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -70,5 +70,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtXml.pc|${PREFIX}/libdata/pkgconfig/QtXml.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 879f7b14e335..791dcb01a324 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gui
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= x11-toolkits
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -95,5 +95,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtGui.pc|${PREFIX}/libdata/pkgconfig/QtGui.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 8438b5580b9d..37028a719bb7 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -8,7 +8,7 @@
PORTNAME= opengl
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= x11
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -73,5 +73,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/QtOpenGL.pc|${PREFIX}/libdata/pkgconfig/QtOpenGL.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>