aboutsummaryrefslogtreecommitdiff
path: root/devel/qt4-qt3support/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/qt4-qt3support/Makefile')
-rw-r--r--devel/qt4-qt3support/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/qt4-qt3support/Makefile b/devel/qt4-qt3support/Makefile
index 6280e90f6b3b..e4bddbffc32c 100644
--- a/devel/qt4-qt3support/Makefile
+++ b/devel/qt4-qt3support/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qt3support
PORTVERSION= 4.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES?= devel x11-toolkits
MASTER_SITES= ${MASTER_SITE_QT}
PKGNAMEPREFIX= qt4-
@@ -72,5 +72,9 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/Qt3Support.pc|${PREFIX}/libdata/pkgconfig/Qt3Support.pc|g' \
${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
+ -E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
+ -E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
+ ${WRKSRC}/../../lib/*Qt*
.include <bsd.port.post.mk>