aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/Makefile1
-rw-r--r--math/mpfrcx/Makefile33
-rw-r--r--math/mpfrcx/distinfo3
-rw-r--r--math/mpfrcx/pkg-descr10
4 files changed, 47 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 5fb3be7e8332..dbd81cb7f93b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -414,6 +414,7 @@
SUBDIR += mpfi
SUBDIR += mpfr
SUBDIR += mpfrc++
+ SUBDIR += mpfrcx
SUBDIR += mpir
SUBDIR += mppp
SUBDIR += mprime
diff --git a/math/mpfrcx/Makefile b/math/mpfrcx/Makefile
new file mode 100644
index 000000000000..d9450fd498a3
--- /dev/null
+++ b/math/mpfrcx/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= mpfrcx
+DISTVERSION= 0.6
+CATEGORIES= math
+MASTER_SITES= http://www.multiprecision.org/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Arbitrary precision library for arithmetic of univariate polynomials
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpc.so:math/mpc \
+ libmpfr.so:math/mpfr
+
+USES= gmake libtool localbase
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+INFO= mpfrcx
+
+PLIST_FILES= include/mpfrcx.h \
+ lib/libmpfrcx.a \
+ lib/libmpfrcx.so \
+ lib/libmpfrcx.so.1 \
+ lib/libmpfrcx.so.1.2.0
+
+.include <bsd.port.mk>
diff --git a/math/mpfrcx/distinfo b/math/mpfrcx/distinfo
new file mode 100644
index 000000000000..11ca165e3a50
--- /dev/null
+++ b/math/mpfrcx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609883286
+SHA256 (mpfrcx-0.6.tar.gz) = 2af256e0f0a4410e1fd1c377260ba0c8cd969a6513db795dcc52509554cde53f
+SIZE (mpfrcx-0.6.tar.gz) = 679718
diff --git a/math/mpfrcx/pkg-descr b/math/mpfrcx/pkg-descr
new file mode 100644
index 000000000000..2f7150f71cc0
--- /dev/null
+++ b/math/mpfrcx/pkg-descr
@@ -0,0 +1,10 @@
+MPFRCX is a library for the arithmetic of univariate polynomials over arbitrary
+precision real (GNU MPFR) or complex (GNU MPC) numbers, without control on the
+rounding. The functions implemented are not very numerous and somewhat
+idiosyncratic: the main motivation behind the library is to have functionality
+available for the floating-point approach to complex multiplication. However,
+asymptotically fast routines such as Toom-Cook and the FFT for multiplication of
+polynomials are available, as well as fast routines for interpolation and
+evaluation based on trees of polynomials.
+
+WWW: http://www.multiprecision.org/mpfrcx/home.html