aboutsummaryrefslogtreecommitdiff
path: root/math/mpfrcx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/mpfrcx/Makefile')
-rw-r--r--math/mpfrcx/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/math/mpfrcx/Makefile b/math/mpfrcx/Makefile
new file mode 100644
index 000000000000..d9450fd498a3
--- /dev/null
+++ b/math/mpfrcx/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= mpfrcx
+DISTVERSION= 0.6
+CATEGORIES= math
+MASTER_SITES= http://www.multiprecision.org/downloads/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Arbitrary precision library for arithmetic of univariate polynomials
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpc.so:math/mpc \
+ libmpfr.so:math/mpfr
+
+USES= gmake libtool localbase
+USE_LDCONFIG= yes
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+INFO= mpfrcx
+
+PLIST_FILES= include/mpfrcx.h \
+ lib/libmpfrcx.a \
+ lib/libmpfrcx.so \
+ lib/libmpfrcx.so.1 \
+ lib/libmpfrcx.so.1.2.0
+
+.include <bsd.port.mk>