aboutsummaryrefslogtreecommitdiff
path: root/devel/gmake
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gmake')
-rw-r--r--devel/gmake/Makefile21
-rw-r--r--devel/gmake/distinfo6
-rw-r--r--devel/gmake/files/patch-10-6e6abd0c127
-rw-r--r--devel/gmake/files/patch-configure11
-rw-r--r--devel/gmake/files/patch-lib-glob.c10
-rw-r--r--devel/gmake/files/patch-src-default.c11
-rw-r--r--devel/gmake/files/patch-src-makeint.h10
-rw-r--r--devel/gmake/pkg-descr2
-rw-r--r--devel/gmake/pkg-plist3
9 files changed, 26 insertions, 175 deletions
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index df99d624bc02..f0c981b4b221 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -1,27 +1,28 @@
-# Created by: jkh
-
-PORTNAME= gmake
-PORTVERSION= 4.3
-PORTREVISION= 2
+PORTNAME= make
+DISTVERSION= 4.4.1
CATEGORIES= devel
-MASTER_SITES= GNU/make
-DISTNAME= make-${PORTVERSION}
+MASTER_SITES= GNU
+PKGNAMEPREFIX= g
# note: before committing to this port, contact portmgr to arrange for an
# experimental ports run. Untested commits may be backed out at portmgr's
# discretion.
MAINTAINER= tijl@FreeBSD.org
COMMENT= GNU version of 'make' utility
+WWW= https://www.gnu.org/software/make/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= cpe tar:lz
+CPE_VENDOR= gnu
+
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --program-prefix=g \
--without-guile
-USES= cpe tar:lz
-CPE_VENDOR= gnu
+INFO= make
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
@@ -29,6 +30,4 @@ OPTIONS_SUB= yes
NLS_USES= gettext-runtime
NLS_CONFIGURE_ENABLE= nls
-INFO= make
-
.include <bsd.port.mk>
diff --git a/devel/gmake/distinfo b/devel/gmake/distinfo
index b8f83469ce24..76567dedc173 100644
--- a/devel/gmake/distinfo
+++ b/devel/gmake/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587222848
-SHA256 (make-4.3.tar.lz) = de1a441c4edf952521db30bfca80baae86a0ff1acd0a00402999344f04c45e82
-SIZE (make-4.3.tar.lz) = 1266180
+TIMESTAMP = 1687757277
+SHA256 (make-4.4.1.tar.lz) = 8814ba072182b605d156d7589c19a43b89fc58ea479b9355146160946f8cf6e9
+SIZE (make-4.4.1.tar.lz) = 1305648
diff --git a/devel/gmake/files/patch-10-6e6abd0c b/devel/gmake/files/patch-10-6e6abd0c
deleted file mode 100644
index 9e0f1e22caa8..000000000000
--- a/devel/gmake/files/patch-10-6e6abd0c
+++ /dev/null
@@ -1,127 +0,0 @@
-From: Bruno Haible <bruno@clisp.org>
-Date: Sat, 23 May 2020 10:19:34 +0000 (+0200)
-Subject: findprog-in: Ignore directories.
-X-Git-Url: https://git.savannah.gnu.org/gitweb/?p=gnulib.git;a=commitdiff_plain;h=6e6abd0cdfe4bb96f6412aebc511f10bf254a820
-
-findprog-in: Ignore directories.
-
-Reported by Frederick Eaton via Dmitry Goncharov in
-<https://lists.gnu.org/archive/html/bug-gnulib/2020-03/msg00003.html>.
-
-* lib/findprog-in.c (find_in_given_path): When the file found is a
-directory, set errno to EACCES and, during a PATH search, continue
-searching.
-* modules/findprog-in (Depends-on): Add sys_stat, stat.
----
-
-diff --git a/lib/findprog-in.c b/lib/findprog-in.c
-index c254f2f..0f76e36 100644
---- lib/findprog-in.c
-+++ lib/findprog-in.c
-@@ -26,6 +26,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <unistd.h>
-+#include <sys/stat.h>
-
- #include "filename.h"
- #include "concat-filename.h"
-@@ -58,8 +59,8 @@ static const char * const suffixes[] =
- /* Note: The cmd.exe program does a different lookup: It searches according
- to the PATHEXT environment variable.
- See <https://stackoverflow.com/questions/7839150/>.
-- Also, it executes files ending .bat and .cmd directly without letting the
-- kernel interpret the program file. */
-+ Also, it executes files ending in .bat and .cmd directly without letting
-+ the kernel interpret the program file. */
- #elif defined __CYGWIN__
- "", ".exe", ".com"
- #elif defined __EMX__
-@@ -136,14 +137,26 @@ find_in_given_path (const char *progname, const char *path,
- call access() despite its design flaw. */
- if (eaccess (progpathname, X_OK) == 0)
- {
-- /* Found! */
-- if (strcmp (progpathname, progname) == 0)
-+ /* Check that the progpathname does not point to a
-+ directory. */
-+ struct stat statbuf;
-+
-+ if (stat (progpathname, &statbuf) >= 0)
- {
-- free (progpathname);
-- return progname;
-+ if (! S_ISDIR (statbuf.st_mode))
-+ {
-+ /* Found! */
-+ if (strcmp (progpathname, progname) == 0)
-+ {
-+ free (progpathname);
-+ return progname;
-+ }
-+ else
-+ return progpathname;
-+ }
-+
-+ errno = EACCES;
- }
-- else
-- return progpathname;
- }
-
- if (errno != ENOENT)
-@@ -210,25 +223,37 @@ find_in_given_path (const char *progname, const char *path,
- call access() despite its design flaw. */
- if (eaccess (progpathname, X_OK) == 0)
- {
-- /* Found! */
-- if (strcmp (progpathname, progname) == 0)
-+ /* Check that the progpathname does not point to a
-+ directory. */
-+ struct stat statbuf;
-+
-+ if (stat (progpathname, &statbuf) >= 0)
- {
-- free (progpathname);
--
-- /* Add the "./" prefix for real, that
-- xconcatenated_filename() optimized away. This
-- avoids a second PATH search when the caller uses
-- execl/execv/execlp/execvp. */
-- progpathname =
-- XNMALLOC (2 + strlen (progname) + 1, char);
-- progpathname[0] = '.';
-- progpathname[1] = NATIVE_SLASH;
-- memcpy (progpathname + 2, progname,
-- strlen (progname) + 1);
-- }
-+ if (! S_ISDIR (statbuf.st_mode))
-+ {
-+ /* Found! */
-+ if (strcmp (progpathname, progname) == 0)
-+ {
-+ free (progpathname);
-+
-+ /* Add the "./" prefix for real, that
-+ xconcatenated_filename() optimized away.
-+ This avoids a second PATH search when the
-+ caller uses execl/execv/execlp/execvp. */
-+ progpathname =
-+ XNMALLOC (2 + strlen (progname) + 1, char);
-+ progpathname[0] = '.';
-+ progpathname[1] = NATIVE_SLASH;
-+ memcpy (progpathname + 2, progname,
-+ strlen (progname) + 1);
-+ }
-+
-+ free (path_copy);
-+ return progpathname;
-+ }
-
-- free (path_copy);
-- return progpathname;
-+ errno = EACCES;
-+ }
- }
-
- if (errno != ENOENT)
diff --git a/devel/gmake/files/patch-configure b/devel/gmake/files/patch-configure
new file mode 100644
index 000000000000..c8beba7802ea
--- /dev/null
+++ b/devel/gmake/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2023-02-26 18:46:38 UTC
++++ configure
+@@ -6741,7 +6741,7 @@ fi
+
+
+
+-printf "%s\n" "#define MAKE_CXX \"$CXX\"" >>confdefs.h
++printf "%s\n" "#define MAKE_CXX \"c++\"" >>confdefs.h
+
+
+ # Configure gnulib
diff --git a/devel/gmake/files/patch-lib-glob.c b/devel/gmake/files/patch-lib-glob.c
deleted file mode 100644
index a51d38144d88..000000000000
--- a/devel/gmake/files/patch-lib-glob.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/glob.c.orig 2020-01-03 07:11:27 UTC
-+++ lib/glob.c
-@@ -203,7 +203,6 @@ my_realloc (p, n)
- return (char *) malloc (n);
- return (char *) realloc (p, n);
- }
--# define realloc my_realloc
- # endif /* __SASC */
- #endif /* __GNU_LIBRARY__ || __DJGPP__ */
-
diff --git a/devel/gmake/files/patch-src-default.c b/devel/gmake/files/patch-src-default.c
deleted file mode 100644
index df78eb415b2e..000000000000
--- a/devel/gmake/files/patch-src-default.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/default.c.orig 2020-01-03 07:11:27 UTC
-+++ src/default.c
-@@ -530,7 +530,7 @@ static const char *default_variables[] =
- "OBJC", "gcc",
- #else
- "CC", "cc",
-- "CXX", "g++",
-+ "CXX", "c++",
- "OBJC", "cc",
- #endif
-
diff --git a/devel/gmake/files/patch-src-makeint.h b/devel/gmake/files/patch-src-makeint.h
deleted file mode 100644
index 0bf6dad2f146..000000000000
--- a/devel/gmake/files/patch-src-makeint.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/makeint.h.orig 2020-01-19 20:32:59 UTC
-+++ src/makeint.h
-@@ -116,7 +116,6 @@ extern int errno;
-
- /* Some systems define _POSIX_VERSION but are not really POSIX.1. */
- #if (defined (butterfly) || defined (__arm) || (defined (__mips) && defined (_SYSTYPE_SVR3)) || (defined (sequent) && defined (i386)))
--# undef POSIX
- #endif
-
- #if !defined (POSIX) && defined (_AIX) && defined (_POSIX_SOURCE)
diff --git a/devel/gmake/pkg-descr b/devel/gmake/pkg-descr
index 456196b965a1..9e064d213a00 100644
--- a/devel/gmake/pkg-descr
+++ b/devel/gmake/pkg-descr
@@ -1,5 +1,3 @@
GNU make is a tool that controls the generation of executables and other
non-source files from source files. Its purpose is the same as that
of the utility make(1).
-
-WWW: https://www.gnu.org/software/make/
diff --git a/devel/gmake/pkg-plist b/devel/gmake/pkg-plist
index ec60fd19c420..0bd0d215c14f 100644
--- a/devel/gmake/pkg-plist
+++ b/devel/gmake/pkg-plist
@@ -21,6 +21,7 @@ include/gnumake.h
%%NLS%%share/locale/pl/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt/LC_MESSAGES/make.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/make.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/make.mo
%%NLS%%share/locale/ru/LC_MESSAGES/make.mo
%%NLS%%share/locale/sr/LC_MESSAGES/make.mo
%%NLS%%share/locale/sv/LC_MESSAGES/make.mo
@@ -29,4 +30,4 @@ include/gnumake.h
%%NLS%%share/locale/vi/LC_MESSAGES/make.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/make.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/make.mo
-man/man1/gmake.1.gz
+share/man/man1/gmake.1.gz