aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/sane-backends/Makefile36
-rw-r--r--graphics/sane-backends/distinfo8
-rw-r--r--graphics/sane-backends/files/patch-backend__Makefile.in25
3 files changed, 27 insertions, 42 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index ffb745c30d20..b29778c28b50 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -2,33 +2,24 @@
# $FreeBSD$
PORTNAME= sane-backends
-PORTVERSION= 1.0.23
-PORTREVISION= 2
+PORTVERSION= 1.0.24
CATEGORIES= graphics
-MASTER_SITES= http://alioth.debian.org/frs/download.php/3752/:3752 \
- http://alioth.debian.org/frs/download.php/3753/:3753 \
- http://alioth.debian.org/frs/download.php/3754/:3754 \
- ftp://ftp2.sane-project.org/pub/sane/
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}.1:3752,DEFAULT \
- ${DISTNAME}${EXTRACT_SUFX}.2:3753,DEFAULT \
- ${DISTNAME}${EXTRACT_SUFX}.3:3754,DEFAULT
-EXTRACT_ONLY= # need to concatenate before extraction
+MASTER_SITES= http://alioth.debian.org/frs/download.php/3958/ \
+ http://fossies.org/linux/misc/
MAINTAINER= ports@FreeBSD.org
COMMENT= API for access to scanners, digitals camera, frame grabbers etc
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2 # (or later)
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libv4l1.so:${PORTSDIR}/multimedia/libv4l
OPTIONS_DEFINE= AVAHI CUPS DOCS GPHOTO IEEE1284 IPV6 NLS SNMP USB
-OPTIONS_DEFAULT= USB
+OPTIONS_DEFAULT= USB IPV6
OPTIONS_SUB= yes
-
+IEEE1284_DESC= Pararell port support via libieee1284
USB_DESC= USB support
-IEEE1284_DESC= libieee1284 support
USES= gmake pathfix pkgconfig
GNU_CONFIGURE= yes
@@ -58,15 +49,15 @@ GPHOTO_LIB_DEPENDS= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
IEEE1284_LIB_DEPENDS= libieee1284.so:${PORTSDIR}/sysutils/libieee1284
-IPV6_CONFIGURE_OFF= --disable-ipv6
+IPV6_CONFIGURE_ENABLE= ipv6
-NLS_CONFIGURE_OFF= --disable-translations
+NLS_CONFIGURE_ENABLE= translations
NLS_USES= gettext
-SNMP_CONFIGURE_OFF= --without-snmp
+SNMP_CONFIGURE_WITH= snmp
SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
-USB_CONFIGURE_OFF= --disable-libusb
+USB_CONFIGURE_ENABLE= libusb
.include <bsd.port.options.mk>
@@ -84,8 +75,8 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e '/^for ac_header in/s|libc.h|cups/cups.h| ; \
- s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"| ; \
- s|-pthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
+ s|-e .*/cups.h|"$$ac_cv_header_cups_cups_h" = "yes"|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^dist_doc_DATA/s|COPYING||' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/^pkgconfigdir/s|@libdir@|@prefix@/libdata|' \
@@ -93,7 +84,4 @@ post-patch:
@${REINPLACE_CMD} -e '/^export PKG_CONFIG_LIBDIR=/s|@libdir@|@prefix@/libdata|' \
${WRKSRC}/tools/sane-config.in
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/graphics/sane-backends/distinfo b/graphics/sane-backends/distinfo
index 20c5e10ca03d..5ccb7c49f75e 100644
--- a/graphics/sane-backends/distinfo
+++ b/graphics/sane-backends/distinfo
@@ -1,6 +1,2 @@
-SHA256 (sane-backends-1.0.23.tar.gz.1) = 551d7e0c89d18ca438bfce4f1c242b59485195c493c5f935a3b11e724ee39537
-SIZE (sane-backends-1.0.23.tar.gz.1) = 1792000
-SHA256 (sane-backends-1.0.23.tar.gz.2) = b487df0d8dc921803577ee34ceaa676a4a3b6715cd4d9a229b43d6a501a1baab
-SIZE (sane-backends-1.0.23.tar.gz.2) = 1792000
-SHA256 (sane-backends-1.0.23.tar.gz.3) = af91e84cb72dc2b1fa4c7eaba948ae6ab8e2ab353f79805a21de4ac52de5b81a
-SIZE (sane-backends-1.0.23.tar.gz.3) = 1758350
+SHA256 (sane-backends-1.0.24.tar.gz) = 27c7085a54f1505d8b551e6f1e69d30e1ee57328b18429bb2225dabf4c45462d
+SIZE (sane-backends-1.0.24.tar.gz) = 5778749
diff --git a/graphics/sane-backends/files/patch-backend__Makefile.in b/graphics/sane-backends/files/patch-backend__Makefile.in
index 93d0e1becbbb..8ded1b343d72 100644
--- a/graphics/sane-backends/files/patch-backend__Makefile.in
+++ b/graphics/sane-backends/files/patch-backend__Makefile.in
@@ -1,15 +1,15 @@
---- backend/Makefile.in.orig 2010-04-14 09:52:59.000000000 +0900
-+++ backend/Makefile.in 2010-05-10 21:51:54.000000000 +0900
-@@ -1244,7 +1244,7 @@
- libxerox_mfp_la_LIBADD =
- am_libxerox_mfp_la_OBJECTS = libxerox_mfp_la-xerox_mfp.lo
- libxerox_mfp_la_OBJECTS = $(am_libxerox_mfp_la_OBJECTS)
+--- ./backend/Makefile.in.orig 2014-01-05 18:05:50.000000000 -0200
++++ ./backend/Makefile.in 2014-01-05 18:06:53.000000000 -0200
+@@ -1470,7 +1470,7 @@
+ am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
+ am__v_at_0 = @
+ am__v_at_1 =
-DEFAULT_INCLUDES = -I.@am__isrc@ -I$(top_builddir)/include/sane
+DEFAULT_INCLUDES = -I$(top_builddir)/include/sane -I$(top_builddir)/include -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
am__mv = mv -f
-@@ -4701,7 +4701,7 @@
+@@ -5385,7 +5385,7 @@
@# installed library in $(sanelibdir) to $(sanelibdir)/libsane.*.
@# Having two libsane's can cause issues so get rid of it.
-rm -f $(DESTDIR)$(sanelibdir)/libsane.*
@@ -18,11 +18,12 @@
test -z "$(configdir)/dll.d" || $(MKDIR_P) "$(DESTDIR)$(configdir)/dll.d"
@list="$(BACKEND_CONFS_ENABLED) saned.conf dll.conf"; for cfg in $$list; do \
if test ! -r $${cfg}; then continue; fi; \
-@@ -4712,6 +4712,7 @@
- $(INSTALL_DATA) $${cfg} $(DESTDIR)$(configdir)/$${cfg} \
+@@ -5393,7 +5393,7 @@
+ echo NOT overwriting $${cfg} in $(configdir)...; \
+ else \
+ echo installing $${cfg} in $(configdir)/$${cfg}...; \
+- $(INSTALL_DATA) $${cfg} $(DESTDIR)$(configdir)/$${cfg} \
++ $(INSTALL_DATA) $${cfg} $(DESTDIR)$(configdir)/dist/$${cfg} \
|| exit 1; \
fi; \
-+ $(INSTALL_DATA) $${cfg} $(DESTDIR)$(configdir)/dist/$${cfg}; \
done
-
- install-firmware-path: