aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/bcusdk-eibd/Makefile2
-rw-r--r--net/clamz/Makefile6
-rw-r--r--net/cnet/Makefile2
-rw-r--r--net/coda6_server/Makefile6
-rw-r--r--net/daemonlogger/Makefile2
-rw-r--r--net/desktop-data-model/Makefile8
-rw-r--r--net/dhcperf/Makefile2
-rw-r--r--net/freeswitch-core-devel/Makefile16
-rw-r--r--net/ifstated/Makefile2
-rw-r--r--net/ldapsdk/Makefile2
-rw-r--r--net/mad_fcl/Makefile2
-rw-r--r--net/mediatomb/Makefile2
-rw-r--r--net/mmucl/Makefile2
-rw-r--r--net/mpich2/Makefile2
-rw-r--r--net/nepenthes/Makefile10
-rw-r--r--net/openam/Makefile2
-rw-r--r--net/openmcu/Makefile2
-rw-r--r--net/openser/Makefile2
-rw-r--r--net/p5-Net-SSH2/Makefile2
-rw-r--r--net/pecl-amqp/Makefile2
-rw-r--r--net/pecl-geoip/Makefile2
-rw-r--r--net/py-qt4-network/Makefile2
-rw-r--r--net/qoauth/Makefile2
-rw-r--r--net/qtweetlib/Makefile2
-rw-r--r--net/quagga-re/Makefile2
-rw-r--r--net/rtpproxy/Makefile2
-rw-r--r--net/ruby-net-geoip/Makefile2
-rw-r--r--net/ser/Makefile2
-rw-r--r--net/silc-server/Makefile2
-rw-r--r--net/spserver/Makefile2
-rw-r--r--net/tcpdump/Makefile2
-rw-r--r--net/wmlj/Makefile2
-rw-r--r--net/xrdp-devel/Makefile2
33 files changed, 51 insertions, 51 deletions
diff --git a/net/bcusdk-eibd/Makefile b/net/bcusdk-eibd/Makefile
index 81cb6866039c..4e9d0e0ebe10 100644
--- a/net/bcusdk-eibd/Makefile
+++ b/net/bcusdk-eibd/Makefile
@@ -11,7 +11,7 @@ DISTFILES= ${PORTNAME}_${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= bkoenig@alpha-tierchen.de
COMMENT= The EIBnet/IP server of the BCU SDK
-LIB_DEPENDS= pthsem.20:${PORTSDIR}/devel/pthsem
+LIB_DEPENDS= libpthsem.so:${PORTSDIR}/devel/pthsem
BUILD_DEPENDS= ${LOCALBASE}/lib/libargp.a:${PORTSDIR}/devel/argp-standalone
GNU_CONFIGURE= yes
diff --git a/net/clamz/Makefile b/net/clamz/Makefile
index 86c1518d652a..a476cb74d613 100644
--- a/net/clamz/Makefile
+++ b/net/clamz/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= glathe.helko@googlemail.com
COMMENT= Command-line program to download MP3 files from Amazon's music store
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- expat.6:${PORTSDIR}/textproc/expat2 \
- gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgcrypt.so:${PORTSDIR}/security/libgcrypt
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/cnet/Makefile b/net/cnet/Makefile
index 2ab40fb43d73..5f0958d333d0 100644
--- a/net/cnet/Makefile
+++ b/net/cnet/Makefile
@@ -13,7 +13,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Networking simulator
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+LIB_DEPENDS= libtk84.so:${PORTSDIR}/x11-toolkits/tk84
USE_XORG= xpm
USES= gmake
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index f64ed6c1e837..007a16229a18 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -14,9 +14,9 @@ PKGNAMESUFFIX= -${CODA_SUITE}
MAINTAINER= clsung@FreeBSD.org
COMMENT= Server programs for a replicated high-performance network file system
-LIB_DEPENDS= lwp.2:${PORTSDIR}/devel/lwp \
- rpc2.9:${PORTSDIR}/devel/rpc2 \
- rvmlwp.3:${PORTSDIR}/devel/rvm
+LIB_DEPENDS= liblwp.so:${PORTSDIR}/devel/lwp \
+ librpc2.so:${PORTSDIR}/devel/rpc2 \
+ librvmlwp.so:${PORTSDIR}/devel/rvm
USES= pkgconfig gmake
GNU_CONFIGURE= yes
diff --git a/net/daemonlogger/Makefile b/net/daemonlogger/Makefile
index 416a3a8376d6..9a69fafc8217 100644
--- a/net/daemonlogger/Makefile
+++ b/net/daemonlogger/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= http://www.snort.org/users/roesch/code/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Packet sniffer capable of running as a daemon and as a software tap
-LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
+LIB_DEPENDS= libdnet.so:${PORTSDIR}/net/libdnet
GNU_CONFIGURE= yes
USE_RC_SUBR= daemonlogger
diff --git a/net/desktop-data-model/Makefile b/net/desktop-data-model/Makefile
index ef8e60638986..df140a45f89a 100644
--- a/net/desktop-data-model/Makefile
+++ b/net/desktop-data-model/Makefile
@@ -18,11 +18,11 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libpcre.pc:${PORTSDIR}/devel/pcre
${LOCALBASE}/libdata/pkgconfig/dbus-glib-1.pc:${PORTSDIR}/devel/dbus-glib \
${LOCALBASE}/libdata/pkgconfig/sqlite3.pc:${PORTSDIR}/databases/sqlite3 \
${LOCALBASE}/libdata/pkgconfig/loudmouth-1.0.pc:${PORTSDIR}/net-im/loudmouth
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
- dbus-1.3:${PORTSDIR}/devel/dbus \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
+ libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libsqlite3.so:${PORTSDIR}/databases/sqlite3 \
- loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+ libloudmouth-1.so:${PORTSDIR}/net-im/loudmouth
USES= gettext gmake pkgconfig tar:bzip2
USE_GNOME= gnomehack gtk20 glib20 gnomedesktop gnomevfs2
diff --git a/net/dhcperf/Makefile b/net/dhcperf/Makefile
index dd690039bd32..55b4452c14c0 100644
--- a/net/dhcperf/Makefile
+++ b/net/dhcperf/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-1-freebsd-5.4-i386
MAINTAINER= edwin@mavetju.org
COMMENT= DHCPerf delivers accurate performance metrics of Dynamic Host Configuration Protocol service
-LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+LIB_DEPENDS= libc.so.5:${PORTSDIR}/misc/compat5x
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Rebuild of i386 package provided by Nominum.
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index bd25da82b657..fb84047c9473 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -30,10 +30,10 @@ EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}.tar.bz2
MAINTAINER= ports@FreeBSD.org
COMMENT= FreeSwitch SoftSwitch Port
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libodbc.so:${PORTSDIR}/databases/unixODBC
CONFLICTS= freeswitch-core-[0-9]*
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
@@ -198,17 +198,17 @@ PLIST_SUB+= ${opt}="@comment "
.if ${PORT_OPTIONS:MMODFREETDM}
CONFIGURE_ARGS+= --with-libpri=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/include/dahdi/wctdm_user.h:${PORTSDIR}/misc/dahdi
-LIB_DEPENDS+= pri:${PORTSDIR}/misc/libpri
+LIB_DEPENDS+= libpri.so:${PORTSDIR}/misc/libpri
RUN_DEPENDS+= ${LOCALBASE}/include/dahdi/wctdm_user.h:${PORTSDIR}/misc/dahdi
.endif
.if ${PORT_OPTIONS:MMODSHOUT}
-LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
.endif
.if ${PORT_OPTIONS:MMODPERL}
USE_BDB= 42+
-LIB_DEPENDS+= gdbm:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS+= libgdbm.so:${PORTSDIR}/databases/gdbm
.endif
.if ${PORT_OPTIONS:MMODERLANGEVENT}
@@ -242,7 +242,7 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/ladspa/amp.so:${PORTSDIR}/audio/ladspa \
.endif
.if ${PORT_OPTIONS:MMODVLC}
-LIB_DEPENDS+= vlc:/${PORTSDIR}/multimedia/vlc
+LIB_DEPENDS+= libvlc.so:${PORTSDIR}/multimedia/vlc
RUN_DEPENDS+= vlc:/${PORTSDIR}/multimedia/vlc
.endif
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index 1e8ab0c46b99..75b727cdc4b7 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://christianserving.org/ports/net/ifstated/
MAINTAINER= ports@christianserving.org
COMMENT= Interface state daemon
-LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
PLIST_FILES= etc/ifstated.conf-sample \
sbin/ifstated \
diff --git a/net/ldapsdk/Makefile b/net/ldapsdk/Makefile
index 48695001482a..ed36468c22a6 100644
--- a/net/ldapsdk/Makefile
+++ b/net/ldapsdk/Makefile
@@ -11,7 +11,7 @@ DISTNAME= mozldap-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mozilla LDAP sdk
-LIB_DEPENDS= nspr4.1:${PORTSDIR}/devel/nspr
+LIB_DEPENDS= libnspr4.so:${PORTSDIR}/devel/nspr
WRKSRC= ${WRKDIR}/${DISTNAME}/c-sdk
diff --git a/net/mad_fcl/Makefile b/net/mad_fcl/Makefile
index a6d6d3e4aeb5..b2e7c7551077 100644
--- a/net/mad_fcl/Makefile
+++ b/net/mad_fcl/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}_v${PORTVERSION}_src
MAINTAINER= jmohacsi@bsd.hu
COMMENT= FLUTE - File Delivery over Unidirectional Transport implementation
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
USES= gmake
USE_OPENSSL= yes
diff --git a/net/mediatomb/Makefile b/net/mediatomb/Makefile
index ac70d9efa04b..cb49b89aaff6 100644
--- a/net/mediatomb/Makefile
+++ b/net/mediatomb/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/MediaTomb/${PORTVERSION}
MAINTAINER= leo@mediatomb.cc
COMMENT= UPnP AV MediaServer
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
GNU_CONFIGURE= yes
LDFLAGS+= ${PTHREAD_LIBS}
diff --git a/net/mmucl/Makefile b/net/mmucl/Makefile
index 082aaab932b3..be88f207ab28 100644
--- a/net/mmucl/Makefile
+++ b/net/mmucl/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= tim@SPYDERWEB.COM.AU
COMMENT= Powerful GUI MUD client written in TCL
-LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84
+LIB_DEPENDS= libtcl84.so:${PORTSDIR}/lang/tcl84
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
USES= gmake
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 0664df56f93b..df53749607aa 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -18,7 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
GNU_CONFIGURE= yes
diff --git a/net/nepenthes/Makefile b/net/nepenthes/Makefile
index d34ec60df22d..1f3648ea2344 100644
--- a/net/nepenthes/Makefile
+++ b/net/nepenthes/Makefile
@@ -10,13 +10,13 @@ MASTER_SITES= SF/${PORTNAME}/Nepenthes%20development/${PORTVERSION}
MAINTAINER= systemoperator@gmail.com
COMMENT= Determine the malware activity on a network
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- magic.1:${PORTSDIR}/sysutils/file \
- pcre.3:${PORTSDIR}/devel/pcre \
- adns.1:${PORTSDIR}/dns/adns
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libmagic.so:${PORTSDIR}/sysutils/file \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libadns.so:${PORTSDIR}/dns/adns
.if defined(WITH_PRELUDE)
-LIB_DEPENDS+= prelude:${PORTSDIR}/security/libprelude
+LIB_DEPENDS+= libprelude.so:${PORTSDIR}/security/libprelude
CONFIGURE_ARGS+= --enable-prelude
.endif
diff --git a/net/openam/Makefile b/net/openam/Makefile
index 9a2cf54573f7..108491402fde 100644
--- a/net/openam/Makefile
+++ b/net/openam/Makefile
@@ -12,7 +12,7 @@ EXTRACT_SUFX= tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= H323 Answer Machine
-LIB_DEPENDS= h323_r.1:${PORTSDIR}/net/openh323
+LIB_DEPENDS= libh323_r.so:${PORTSDIR}/net/openh323
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
diff --git a/net/openmcu/Makefile b/net/openmcu/Makefile
index afc4a3b60aa5..be2be0fb94ef 100644
--- a/net/openmcu/Makefile
+++ b/net/openmcu/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION:S/./_/g}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenMCU hosts a conference call for H323 Video Conferencing users
-LIB_DEPENDS= h323_r.1:${PORTSDIR}/net/openh323
+LIB_DEPENDS= libh323_r.so${PORTSDIR}/net/openh323
WRKSRC= ${WRKDIR}/${PORTNAME}_v${PORTVERSION:S/./_/g}
diff --git a/net/openser/Makefile b/net/openser/Makefile
index 8846a1e5de4a..fa3212bd6798 100644
--- a/net/openser/Makefile
+++ b/net/openser/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-tls_src
MAINTAINER= jesusr@FreeBSD.org
COMMENT= Fast and configurable SIP proxy with TLS support
-LIB_DEPENDS= radiusclient-ng.2:${PORTSDIR}/net/radiusclient
+LIB_DEPENDS= libradiusclient-ng.so:${PORTSDIR}/net/radiusclient
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-tls
diff --git a/net/p5-Net-SSH2/Makefile b/net/p5-Net-SSH2/Makefile
index 3e052375ca79..3d61649ee2d3 100644
--- a/net/p5-Net-SSH2/Makefile
+++ b/net/p5-Net-SSH2/Makefile
@@ -13,7 +13,7 @@ COMMENT= Support for the SSH 2 protocol via libSSH2
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-LIB_DEPENDS= ssh2.1:${PORTSDIR}/security/libssh2
+LIB_DEPENDS= libssh2.so:${PORTSDIR}/security/libssh2
USES= perl5
USE_PERL5= configure
diff --git a/net/pecl-amqp/Makefile b/net/pecl-amqp/Makefile
index fb2a05587c66..698007f538ae 100644
--- a/net/pecl-amqp/Makefile
+++ b/net/pecl-amqp/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= PHP extension for AMQP API
-LIB_DEPENDS= rabbitmq:${PORTSDIR}/net/rabbitmq-c-devel
+LIB_DEPENDS= librabbitmq.so:${PORTSDIR}/net/rabbitmq-c-devel
PHP_MODNAME= ${PORTNAME}
USE_PHP= yes
diff --git a/net/pecl-geoip/Makefile b/net/pecl-geoip/Makefile
index 0e211a6b18ff..8e347f9bd250 100644
--- a/net/pecl-geoip/Makefile
+++ b/net/pecl-geoip/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= clsung@FreeBSD.org
COMMENT= Map IP address to geographic places
-LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
USE_PHP= yes
USE_PHPEXT= yes
diff --git a/net/py-qt4-network/Makefile b/net/py-qt4-network/Makefile
index 38214302f66e..a1db64a6a0bc 100644
--- a/net/py-qt4-network/Makefile
+++ b/net/py-qt4-network/Makefile
@@ -46,7 +46,7 @@ ARGS= -b ${PREFIX}/bin \
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= libqscintilla2.so:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/net/qoauth/Makefile b/net/qoauth/Makefile
index 5fedc9b2627c..9de7f088b780 100644
--- a/net/qoauth/Makefile
+++ b/net/qoauth/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt 4 support for OAuth-powered network services
BUILD_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
-LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
+LIB_DEPENDS= libqca.so:${PORTSDIR}/devel/qca
RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
USES= qmake
diff --git a/net/qtweetlib/Makefile b/net/qtweetlib/Makefile
index 342bda96470b..f857c7ab0e0e 100644
--- a/net/qtweetlib/Makefile
+++ b/net/qtweetlib/Makefile
@@ -10,7 +10,7 @@ COMMENT= C++ Qt based Twitter library
LICENSE= LGPL21
-LIB_DEPENDS= qjson:${PORTSDIR}/devel/qjson
+LIB_DEPENDS= libqjson.so:${PORTSDIR}/devel/qjson
GH_ACCOUNT= minimoog
GH_COMMIT= 2af0b78
diff --git a/net/quagga-re/Makefile b/net/quagga-re/Makefile
index b4059a5d6533..0ef0bacb7bde 100644
--- a/net/quagga-re/Makefile
+++ b/net/quagga-re/Makefile
@@ -22,7 +22,7 @@ USE_AUTOTOOLS= libtool autoheader
USE_LDCONFIG= yes
USE_PERL5= build
BUILD_DEPENDS+= gawk:${PORTSDIR}/lang/gawk
-LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+= --with-libgcrypt
MAN1= vtysh.1
diff --git a/net/rtpproxy/Makefile b/net/rtpproxy/Makefile
index e76f9d3c848d..282d9a810ae7 100644
--- a/net/rtpproxy/Makefile
+++ b/net/rtpproxy/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.rtpproxy.org/chrome/site/
MAINTAINER= sobomax@FreeBSD.org
COMMENT= High-performance RTP proxy server for the SIP Express Router (SER)
-LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
+LIB_DEPENDS= libgsm.so:${PORTSDIR}/audio/gsm
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/net/ruby-net-geoip/Makefile b/net/ruby-net-geoip/Makefile
index 778665f9f3d0..457233bde49b 100644
--- a/net/ruby-net-geoip/Makefile
+++ b/net/ruby-net-geoip/Makefile
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Ruby extension that wraps around libGeoIP
BUILD_DEPENDS= GeoIP>=1.4.6:${PORTSDIR}/net/GeoIP
-LIB_DEPENDS= GeoIP.5:${PORTSDIR}/net/GeoIP
+LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
USES= iconv
USE_RUBY= yes
diff --git a/net/ser/Makefile b/net/ser/Makefile
index 03bd3025b16c..24f62f7bc0b8 100644
--- a/net/ser/Makefile
+++ b/net/ser/Makefile
@@ -59,7 +59,7 @@ MAKE_ENV+= PA=pa
.if !defined(WITHOUT_RADIUS)
PLIST_SUB+= RADIUS=""
-LIB_DEPENDS+= radiusclient-ng.2:${PORTSDIR}/net/radiusclient
+LIB_DEPENDS+= libradiusclient-ng.so:${PORTSDIR}/net/radiusclient
.else
PLIST_SUB+= RADIUS="@comment "
MAKE_ENV+= RADIUS="auth_radius group_radius uri_radius avp_radius"
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index d0ffd81fb602..9a7afac7c854 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -18,7 +18,7 @@ DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
MAINTAINER= wxs@FreeBSD.org
COMMENT= Secure Internet Live Conferencing (SILC) network server
-LIB_DEPENDS= silc-1.1:${PORTSDIR}/devel/silc-toolkit
+LIB_DEPENDS= libsilc-1.1.so:${PORTSDIR}/devel/silc-toolkit
SUB_FILES= pkg-message pkg-deinstall
USE_RC_SUBR= silcd
diff --git a/net/spserver/Makefile b/net/spserver/Makefile
index 6507a70460dc..ab94c2541ba6 100644
--- a/net/spserver/Makefile
+++ b/net/spserver/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= vanilla@FreeBSD.org
COMMENT= TCP server framework library written in C++ based on libevent
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index c9e30103547a..54b14816f236 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://www.tcpdump.org/release/
MAINTAINER= wxs@FreeBSD.org
COMMENT= Ubiquitous network traffic analysis tool
-LIB_DEPENDS= pcap:${PORTSDIR}/net/libpcap
+LIB_DEPENDS= libpcap.so:${PORTSDIR}/net/libpcap
GNU_CONFIGURE= yes
USES= gmake
diff --git a/net/wmlj/Makefile b/net/wmlj/Makefile
index 85e57cba11d7..ee57d1b71bd1 100644
--- a/net/wmlj/Makefile
+++ b/net/wmlj/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Dockapp that monitors your friends list at LiveJournal.com
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
USE_GNOME= gtk12
diff --git a/net/xrdp-devel/Makefile b/net/xrdp-devel/Makefile
index 9b58577e4459..b6f4c7a8a011 100644
--- a/net/xrdp-devel/Makefile
+++ b/net/xrdp-devel/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
CONFLICTS= xrdp-[0-9]*
-LIB_DEPENDS+= jpeg:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
# xrdp v0.7 is not compatible with current net/freerdp (1.0.2)
#BUILD_DEPENDS+= freerdp>=1.0.2:${PORTSDIR}/net/freerdp
#CONFIGURE_ARGS+= --enable-freerdp1