aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/libnghttp2/Makefile17
-rw-r--r--www/libnghttp2/distinfo6
-rw-r--r--www/libnghttp2/files/patch-CMakeLists.txt20
-rw-r--r--www/libnghttp2/files/patch-Makefile.in21
4 files changed, 31 insertions, 33 deletions
diff --git a/www/libnghttp2/Makefile b/www/libnghttp2/Makefile
index 5b3b17eddd77..e9e7c1cbaef6 100644
--- a/www/libnghttp2/Makefile
+++ b/www/libnghttp2/Makefile
@@ -1,8 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.51.0
-PORTREVISION= 1
+DISTVERSION= 1.52.0
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,12 +11,12 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
-
-CONFIGURE_ARGS= --enable-lib-only
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_CXXSTD= c++14
+USES= cmake compiler:c++14-lang cpe libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
+CMAKE_OFF= ENABLE_DOC \
+ ENABLE_HTTP3
+CMAKE_ON= ENABLE_LIB_ONLY \
+ ENABLE_STATIC_LIB
+
.include <bsd.port.mk>
diff --git a/www/libnghttp2/distinfo b/www/libnghttp2/distinfo
index 5c28ff945e0e..367c9878258b 100644
--- a/www/libnghttp2/distinfo
+++ b/www/libnghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1671868303
-SHA256 (nghttp2-1.51.0.tar.xz) = 66aa76d97c143f42295405a31413e5e7d157968dad9f957bb4b015b598882e6b
-SIZE (nghttp2-1.51.0.tar.xz) = 4115988
+TIMESTAMP = 1676359019
+SHA256 (nghttp2-1.52.0.tar.xz) = 3ea9f0439e60469ad4d39cb349938684ffb929dd7e8e06a7bffe9f9d21f8ba7d
+SIZE (nghttp2-1.52.0.tar.xz) = 1491732
diff --git a/www/libnghttp2/files/patch-CMakeLists.txt b/www/libnghttp2/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9eb3864499c1
--- /dev/null
+++ b/www/libnghttp2/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2022-12-24 08:18:29 UTC
++++ CMakeLists.txt
+@@ -503,7 +503,7 @@ include_directories(
+ set(PKGDATADIR "${CMAKE_INSTALL_FULL_DATADIR}/${CMAKE_PROJECT_NAME}")
+ set(PKGLIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}/${CMAKE_PROJECT_NAME}")
+
+-install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
++#install(FILES README.rst DESTINATION "${CMAKE_INSTALL_DOCDIR}")
+
+ add_subdirectory(lib)
+ #add_subdirectory(lib/includes)
+@@ -519,7 +519,7 @@ if(ENABLE_DOC)
+ add_subdirectory(doc)
+ endif()
+ add_subdirectory(contrib)
+-add_subdirectory(script)
++#add_subdirectory(script)
+ add_subdirectory(bpf)
+
+
diff --git a/www/libnghttp2/files/patch-Makefile.in b/www/libnghttp2/files/patch-Makefile.in
deleted file mode 100644
index 3aad251a6069..000000000000
--- a/www/libnghttp2/files/patch-Makefile.in
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.in.orig 2022-11-13 06:53:28 UTC
-+++ Makefile.in
-@@ -465,8 +465,7 @@ top_srcdir = @top_srcdir@
- # LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
- # OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
- # WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
--SUBDIRS = lib third-party src bpf examples python tests integration-tests \
-- doc contrib script
-+SUBDIRS = lib
-
-
- # Now with python setuptools, make uninstall will leave many files we
-@@ -474,7 +473,7 @@ SUBDIRS = lib third-party src bpf examples python test
- # distcheck rule.
- AM_DISTCHECK_CONFIGURE_FLAGS = --disable-python-bindings
- ACLOCAL_AMFLAGS = -I m4
--dist_doc_DATA = README.rst
-+dist_doc_DATA =
- EXTRA_DIST = nghttpx.conf.sample proxy.pac.sample android-config android-env \
- Dockerfile.android \
- cmakeconfig.h.in \