aboutsummaryrefslogtreecommitdiff
path: root/emulators/qtemu
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /emulators/qtemu
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'emulators/qtemu')
-rw-r--r--emulators/qtemu/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 066f5a545619..6ebddf983e49 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -12,8 +12,8 @@ COMMENT= Qt 4 based frontend for QEMU
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake tar:bzip2
-USE_QT4= gui xml uic_build moc_build rcc_build
+USES= qmake qt:4 tar:bzip2
+USE_QT= gui xml uic_build moc_build rcc_build
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
@@ -22,7 +22,8 @@ DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USE= QT4=linguisttools_build
+NLS_USES= qt:4
+NLS_USE= QT=linguisttools_build
post-configure-NLS-on:
(cd ${WRKSRC} && ${LRELEASE} qtemu.pro)